Troubleshoot crash when using CADFEKO over Microsoft Remote Desktop


Problem

When using CADFEKO over a remote desktop connection and you click on New Project, you may encounter a crash.

Cause

This error can occur when 3D support for remote desktop is disabled for the host machine's graphics card.

Solution

To resolve the issue, enable 3D support on the host machine for remote desktop:

  1. Open the Microsoft Windows Start menu.
  2. Type Local Group Policy and click Edit group policy.
  3. On the Local Group Policy Editor dialog, click Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment.
  4. Enable the following:
    • Use hardware graphics adapters for all Remote Desktop Services sessions
    • Prioritize H.264/AVC 444 graphics mode for Remote Desktop Connections
    • Configure H.264/AVC hardware encoding for Remote Desktop Connections
    • Configure compression for RemoteFX data
    • Configure image quality for RemoteFX Adaptive Graphics
    • Enable RemoteFX encoding for RemoteFX clients designed for Windows Server 2008 R2 SP1
    • Configure RemoteFX Adaptive Graphics
  5. Download and install attached file (nvidiaopenglrdp.exe) for Nvidia graphics card drivers.

 

If the above suggestion did not solve your issue, please contact Altair support.