Fixing Corrupted GlobalUserInterface

Lloyd Lualhati
Lloyd Lualhati
Altair Employee
edited April 8 in Altair RapidMiner

Condition:

This issue is related to Altair Monarch Complete / Altair Monarch Classic fails to open and error "An Unexpected error occurred during the startup" message box appears when starting the application. The error log mentioned contains the following error: "No FontFamily element found in FontFamilyCollection that matches current OS or greater:"

 

Cause:

The cause of this issue is the rollout update by Microsoft that makes the GlobalUserInterface.CompositeFont corrupted.

 

Remedy:

Replacing the corrupted GlobalUserInterface.CompositeFont file with the correct version will fix the issue.

Steps to Follow:

1.         Download GlobalUserInterface.CompositeFont (default download for Windows 7 is %USERPROFILE%\Downloads).

2.         In Windows File Explorer Copy and paste the GlobalUserInterface.CompositeFont file which was downloaded in the previous step to %Windir%\Microsoft.NET\Framework\v4.0.30319\WPF\Fonts.

3.         Copy and paste the GlobalUserInterface.CompositeFont file to %windir%\Microsoft.NET\Framework64\v4.0.30319\WPF\Fonts.

4.         Re-launch Altair Monarch Complete / Altair Monarch Classic application.